unpushed

qutebrowser-3.0.0-2.fc39

FEDORA-2023-23bb8709a5 created by fnux 9 months ago for Fedora 39

Qutebrowser will now use Qtwebengine 6 by default (instead of 5) - which will provide a lot of fixes and improved security. There are no big breaking changes regarding configuration - your setup probably won't break: I'd recommend to check out https://qutebrowser.org/doc/changelog.html if your have a custom / complex environment, though.

(Note that if you want to downgrade from Qtwebengine 6 to Qtwebengine 5 after having used Qtwebengine6, you'll lose navigation history.)

This update has been submitted for testing by fnux.

9 months ago

This update's test gating status has been changed to 'ignored'.

9 months ago

This update has been pushed to testing.

9 months ago

This update's test gating status has been changed to 'passed'.

9 months ago
User Icon ankursinha commented & provided feedback 9 months ago
karma

I can't seem to launch it at all. I get an immediate crash with qt6, even using a temporary basedir with -T . If I force it to use qt5 bits, it still launches.

rpm -qa *qutebrowser* qt* qt5-qttools-common-5.15.10-3.fc39.noarch qt-settings-39.0-1.fc39.noarch qt5-srpm-macros-5.15.10-2.fc39.noarch qt5-qtsvg-5.15.10-2.fc39.x86_64 qt5-qtx11extras-5.15.10-2.fc39.x86_64 qt5-qtwayland-5.15.10-4.fc39.x86_64 qt5-qtdeclarative-5.15.10-2.fc39.x86_64 qt5-qtwebchannel-5.15.10-2.fc39.x86_64 qt5-qtlocation-5.15.10-3.fc39.x86_64 qt5-qtxmlpatterns-5.15.10-2.fc39.x86_64 qt5-qttools-libs-help-5.15.10-3.fc39.x86_64 qt5-qtsensors-5.15.10-2.fc39.x86_64 qt5-qtwebkit-5.212.0-0.78alpha4.fc39.x86_64 qt5-qttools-libs-designer-5.15.10-3.fc39.x86_64 qt5-qtconnectivity-5.15.10-2.fc39.x86_64 qt5-qtgraphicaleffects-5.15.10-2.fc39.x86_64 qt5-qtquickcontrols2-5.15.10-2.fc39.x86_64 qt5-qtscxml-5.15.10-2.fc39.x86_64 qt5-qtserialport-5.15.10-2.fc39.x86_64 qt5-qtwebsockets-5.15.10-2.fc39.x86_64 qt-common-4.8.7-74.fc39.noarch qt-4.8.7-74.fc39.x86_64 qt-x11-4.8.7-74.fc39.x86_64 qt5-qtmultimedia-5.15.10-2.fc39.x86_64 qt5-qtgamepad-5.15.10-2.fc39.x86_64 qt5-qtscript-5.15.10-2.fc39.x86_64 qt5-rpm-macros-5.15.10-2.fc39.noarch qt5-qtbase-common-5.15.10-9.fc39.noarch qt5-qtbase-5.15.10-9.fc39.x86_64 qt6-qttools-common-6.5.2-1.fc39.noarch qt5-qtbase-gui-5.15.10-9.fc39.x86_64 qt6-qtbase-common-6.5.2-5.fc39.noarch qt6-qtsvg-6.5.2-1.fc39.x86_64 qt6-qtbase-gui-6.5.2-5.fc39.x86_64 qt6-qtbase-6.5.2-5.fc39.x86_64 qt6-qtwayland-6.5.2-3.fc39.x86_64 qt6-qtdeclarative-6.5.2-1.fc39.x86_64 qt6-qtspeech-6.5.2-3.fc39.x86_64 qt6-qtspeech-speechd-6.5.2-3.fc39.x86_64 qt6-qtwebchannel-6.5.2-1.fc39.x86_64 qt6-qtpdf-6.5.2-2.fc39.x86_64 qt6-qtserialport-6.5.2-1.fc39.x86_64 qt6-qtpositioning-6.5.2-1.fc39.x86_64 qt6-qtwebengine-6.5.2-2.fc39.x86_64 qt6-qtwebengine-devtools-6.5.2-2.fc39.x86_64 qt6-qtmultimedia-6.5.2-1.fc39.x86_64 qt6-qtquicktimeline-6.5.2-1.fc39.x86_64 qt6-qtremoteobjects-6.5.2-1.fc39.x86_64 qt6-qtsensors-6.5.2-1.fc39.x86_64 qt6-qttools-libs-designer-6.5.2-1.fc39.x86_64 qt6-qtconnectivity-6.5.2-1.fc39.x86_64 qt6-qtshadertools-6.5.2-1.fc39.x86_64 qt6-qtquick3d-6.5.2-1.fc39.x86_64 qt6-qttools-libs-help-6.5.2-1.fc39.x86_64 qt6-qtwebsockets-6.5.2-1.fc39.x86_64 qutebrowser-3.0.0-2.fc39.noarch qtpass-1.4.0-1.fc39.x86_64 qt5-qtbase-devel-5.15.10-9.fc39.x86_64 qt6-srpm-macros-6.5.2-3.fc39.noarch qt5-qtwebengine-5.15.12-8.fc39.x86_64 qt5-qtwebengine-devtools-5.15.12-8.fc39.x86_64 qt5-qtwebengine-freeworld-5.15.12-5.fc39.x86_64

BZ#2232875 qutebrowser-3.0.0 is available

Bodhi is disabling automatic push to stable due to negative karma. The maintainer may push manually if they determine that the issue is not severe.

9 months ago
User Icon ankursinha commented & provided feedback 9 months ago

Filed upstream: https://github.com/qutebrowser/qutebrowser/issues/7927, will file one at our bugzilla too.

This update has been unpushed.


Please login to add feedback.

Metadata
Type
unspecified
Karma
-1
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
disabled
Stable by Time
disabled
Dates
submitted
9 months ago
in testing
9 months ago
BZ#2232875 qutebrowser-3.0.0 is available
0
0

Automated Test Results