stable

ansible-collections-openstack-2.1.0-1.fc38

FEDORA-2023-88df046168 created by amoralej a year ago for Fedora 38

Update to 2.1.0

How to install

Updates may require up to 24 hours to propagate to mirrors. If the following command doesn't work, please retry later:

sudo dnf upgrade --refresh --advisory=FEDORA-2023-88df046168

This update has been submitted for testing by amoralej.

a year ago

This update's test gating status has been changed to 'ignored'.

a year ago
User Icon martinpitt commented & provided feedback a year ago
karma

ansible-inventory works with the dynamic openstack plugin when downgrading to python3-openstacksdk-0.61.0-5.fc37.noarch. I upgraded to the Fedora 38 version again (python3-openstacksdk-0.101.0-2.fc38.noarch), and it fails with the error

Incompatible openstacksdk library found: Version MUST be >=0.36 and <=0.98.999, but 0.101.0 is larger than maximum

version 0.98.999.

as reported in bugzilla.

Then I installed ansible-collections-openstack-2.1.0-1.fc38 from this build (I didn't previously have that installed), and now the dynamic inventory works again. Thanks!

BZ#2218141 openstack collection: Incompatible openstacksdk library found: Version MUST be >=0.36 and <=0.98.999, but 0.101.0 is larger than maximum version 0.98.999

This update has been pushed to testing.

a year ago

This update has been submitted for stable by bodhi.

a year ago

This update has been pushed to stable.

a year ago

Please login to add feedback.

Metadata
Type
bugfix
Severity
medium
Karma
1
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
3
Stable by Time
7 days
Dates
submitted
a year ago
in testing
a year ago
in stable
a year ago
approved
a year ago
BZ#2218141 openstack collection: Incompatible openstacksdk library found: Version MUST be >=0.36 and <=0.98.999, but 0.101.0 is larger than maximum version 0.98.999
0
1

Automated Test Results