stable

fcitx5-qt-5.0.17-5.fc38, kddockwidgets-1.6.0-6.fc38, & 42 more

FEDORA-2023-b1bb4753b3 created by jgrulich 11 months ago for Fedora 38

Qt 6.5.1 bugfix release.


OBS Studio 29.1.2 update

Hotfixes for 29.1.2

  • Fixed a possible crash when interrupting stingers [Lain]
  • Fixed a crash when double-clicking non-multiview projectors [notr1ch]
  • Fixed a crash on opening settings when a non-existent service was selected [derrod]
  • Fixed a crash when receiving multiple SIGINT signals [norihiro]
  • Fixed a crash when closing OBS while a background thread had not completed [norihiro]
  • Fixed an issue that sometimes caused the "Source Cleanup Error" to show when switching scene collections [derrod]
  • Fixed a reference leak with virtual camera when using source output mode [derrod]
  • Fixed an issue where selecting no audio tracks for streaming or recording could cause the output to fail to start [gxalpha]
  • Fixed an issue where sources could become permanently invisible until transform is reset [Lain-B]
  • Fixed audio monitoring when using PulseAudio [jp-bennett]
  • Fixed some translation texts missing [norihiro]
  • Fixed an issue with properties never being updated in some scenarios [gxalpha]
  • Fixed button colors when using the scene list grid mode [TianQiBuTian]
  • Fixed Lua script file names not being set [derrod]

Hotfixes for 29.1.1

  • Fixed audio mixer warning about sources not assigned to any tracks while monitoring was set to "Monitor Only (mute output)" [derrod]
  • Fixed FLAC being erroneously shown as compatible with MOV [derrod]
  • Added an error message for NVENC AV1 to explain why it fails [notr1ch]
  • Fixed a data corruption issue that could occur when switching scene collections [derrod]

How to install

Updates may require up to 24 hours to propagate to mirrors. If the following command doesn't work, please retry later:

sudo dnf upgrade --refresh --advisory=FEDORA-2023-b1bb4753b3

This update's test gating status has been changed to 'waiting'.

11 months ago

This update has been submitted for testing by bodhi.

11 months ago

This update's test gating status has been changed to 'ignored'.

11 months ago
User Icon imabug commented & provided feedback 11 months ago
karma

Got these errors when trying to upgrade

Problem 1: problem with installed package qt6ct-0.8-2.fc38.x86_64
- package qt6ct-0.8-2.fc38.x86_64 from @System requires libQt6Gui.so.6(Qt_6_PRIVATE_API)(64bit), but none of the providers can be installed
- package qt6ct-0.8-2.fc38.x86_64 from updates-testing requires libQt6Gui.so.6(Qt_6_PRIVATE_API)(64bit), but none of the providers can be installed
- cannot install both qt6-qtbase-gui-6.5.1-1.fc38.x86_64 from @commandline and qt6-qtbase-gui-6.5.0-2.fc38.x86_64 from @System
- cannot install both qt6-qtbase-gui-6.5.1-1.fc38.x86_64 from @commandline and qt6-qtbase-gui-6.4.3-1.fc38.x86_64 from fedora
- cannot install both qt6-qtbase-gui-6.5.1-1.fc38.x86_64 from @commandline and qt6-qtbase-gui-6.5.0-2.fc38.x86_64 from updates
- cannot install both qt6-qtbase-gui-6.5.1-1.fc38.x86_64 from @commandline and qt6-qtbase-gui-6.4.3-1.fc38.x86_64 from updates-testing
- cannot install the best update candidate for package qt6-qtbase-gui-6.5.0-2.fc38.x86_64
Problem 2: problem with installed package QXlsx-1.4.6-1.fc38.x86_64
- package QXlsx-1.4.6-1.fc38.x86_64 from @System requires libQt6Gui.so.6(Qt_6_PRIVATE_API)(64bit), but none of the providers can be installed
- package QXlsx-1.4.6-1.fc38.x86_64 from updates requires libQt6Gui.so.6(Qt_6_PRIVATE_API)(64bit), but none of the providers can be installed
- cannot install both qt6-qtbase-gui-6.5.1-1.fc38.x86_64 from @commandline and qt6-qtbase-gui-6.5.0-2.fc38.x86_64 from @System
- cannot install both qt6-qtbase-gui-6.5.1-1.fc38.x86_64 from @commandline and qt6-qtbase-gui-6.4.3-1.fc38.x86_64 from fedora
- cannot install both qt6-qtbase-gui-6.5.1-1.fc38.x86_64 from @commandline and qt6-qtbase-gui-6.5.0-2.fc38.x86_64 from updates
- cannot install both qt6-qtbase-gui-6.5.1-1.fc38.x86_64 from @commandline and qt6-qtbase-gui-6.4.3-1.fc38.x86_64 from updates-testing
- package qgnomeplatform-qt6-0.9.1-3.fc38.x86_64 from @commandline requires libQt6Gui.so.6(Qt_6.5.1_PRIVATE_API)(64bit), but none of the providers can be installed
- cannot install the best update candidate for package qgnomeplatform-qt6-0.9.1-2.fc38.x86_64
Problem 3: problem with installed package stellarium-1.2-9.fc38.x86_64
- package stellarium-1.2-9.fc38.x86_64 from @System requires libQt6Gui.so.6(Qt_6_PRIVATE_API)(64bit), but none of the providers can be installed
- package stellarium-1.2-9.fc38.x86_64 from fedora requires libQt6Gui.so.6(Qt_6_PRIVATE_API)(64bit), but none of the providers can be installed
- package stellarium-1.2-9.fc38.x86_64 from updates-testing requires libQt6Gui.so.6(Qt_6_PRIVATE_API)(64bit), but none of the providers can be installed
- cannot install both qt6-qtbase-gui-6.5.1-1.fc38.x86_64 from @commandline and qt6-qtbase-gui-6.5.0-2.fc38.x86_64 from @System
- cannot install both qt6-qtbase-gui-6.5.1-1.fc38.x86_64 from @commandline and qt6-qtbase-gui-6.4.3-1.fc38.x86_64 from fedora
- cannot install both qt6-qtbase-gui-6.5.1-1.fc38.x86_64 from @commandline and qt6-qtbase-gui-6.5.0-2.fc38.x86_64 from updates
- cannot install both qt6-qtbase-gui-6.5.1-1.fc38.x86_64 from @commandline and qt6-qtbase-gui-6.4.3-1.fc38.x86_64 from updates-testing
- package qt6-doctools-6.5.1-1.fc38.x86_64 from @commandline requires libQt6Gui.so.6(Qt_6.5.1_PRIVATE_API)(64bit), but none of the providers can be installed
- cannot install the best update candidate for package qt6-doctools-6.5.0-1.fc38.x86_64

This update has been pushed to testing.

11 months ago

Bodhi is disabling automatic push to stable due to negative karma. The maintainer may push manually if they determine that the issue is not severe.

11 months ago
User Icon tyrbiter commented & provided feedback 11 months ago
karma

This set of updates gives me these errors:

Problem 1: package qt6ct-0.8-2.fc38.x86_64 from @System requires libQt6Gui.so.6(Qt_6_PRIVATE_API)(64bit), but none of the providers can be installed - cannot install both qt6-qtbase-gui-6.5.1-1.fc38.x86_64 from updates-testing and qt6-qtbase-gui-6.5.0-2.fc38.x86_64 from @System - cannot install both qt6-qtbase-gui-6.5.1-1.fc38.x86_64 from updates-testing and qt6-qtbase-gui-6.4.3-1.fc38.x86_64 from fedora - cannot install both qt6-qtbase-gui-6.5.1-1.fc38.x86_64 from updates-testing and qt6-qtbase-gui-6.5.0-2.fc38.x86_64 from updates - cannot install the best update candidate for package qt6ct-0.8-2.fc38.x86_64 - cannot install the best update candidate for package qt6-qtbase-gui-6.5.0-2.fc38.x86_64 Problem 2: package stellarium-1.2-9.fc38.x86_64 from @System requires libQt6Gui.so.6(Qt_6_PRIVATE_API)(64bit), but none of the providers can be installed - cannot install both qt6-qtbase-gui-6.5.1-1.fc38.x86_64 from updates-testing and qt6-qtbase-gui-6.5.0-2.fc38.x86_64 from @System - cannot install both qt6-qtbase-gui-6.5.1-1.fc38.x86_64 from updates-testing and qt6-qtbase-gui-6.4.3-1.fc38.x86_64 from fedora - cannot install both qt6-qtbase-gui-6.5.1-1.fc38.x86_64 from updates-testing and qt6-qtbase-gui-6.5.0-2.fc38.x86_64 from updates - package qgnomeplatform-qt6-0.9.1-3.fc38.x86_64 from updates-testing requires libQt6Gui.so.6(Qt_6.5.1_PRIVATE_API)(64bit), but none of the providers can be installed - cannot install the best update candidate for package stellarium-1.2-9.fc38.x86_64 - cannot install the best update candidate for package qgnomeplatform-qt6-0.9.1-2.fc38.x86_64 Problem 3: package QXlsx-1.4.6-1.fc38.x86_64 from @System requires libQt6Gui.so.6(Qt_6_PRIVATE_API)(64bit), but none of the providers can be installed - cannot install both qt6-qtbase-gui-6.5.1-1.fc38.x86_64 from updates-testing and qt6-qtbase-gui-6.5.0-2.fc38.x86_64 from @System - cannot install both qt6-qtbase-gui-6.5.1-1.fc38.x86_64 from updates-testing and qt6-qtbase-gui-6.4.3-1.fc38.x86_64 from fedora - cannot install both qt6-qtbase-gui-6.5.1-1.fc38.x86_64 from updates-testing and qt6-qtbase-gui-6.5.0-2.fc38.x86_64 from updates - package qt6-qt3d-6.5.1-1.fc38.x86_64 from updates-testing requires libQt6Gui.so.6(Qt_6.5.1_PRIVATE_API)(64bit), but none of the providers can be installed - cannot install the best update candidate for package qt6-qt3d-6.5.0-1.fc38.x86_64 - cannot install the best update candidate for package QXlsx-1.4.6-1.fc38.x86_64 Problem 4: problem with installed package qt6ct-0.8-2.fc38.x86_64 - package qt6ct-0.8-2.fc38.x86_64 from @System requires libQt6Gui.so.6(Qt_6_PRIVATE_API)(64bit), but none of the providers can be installed - package qt6ct-0.8-2.fc38.x86_64 from updates requires libQt6Gui.so.6(Qt_6_PRIVATE_API)(64bit), but none of the providers can be installed - cannot install both qt6-qtbase-gui-6.5.1-1.fc38.x86_64 from updates-testing and qt6-qtbase-gui-6.5.0-2.fc38.x86_64 from @System - cannot install both qt6-qtbase-gui-6.5.1-1.fc38.x86_64 from updates-testing and qt6-qtbase-gui-6.4.3-1.fc38.x86_64 from fedora - cannot install both qt6-qtbase-gui-6.5.1-1.fc38.x86_64 from updates-testing and qt6-qtbase-gui-6.5.0-2.fc38.x86_64 from updates - package qt6-qt5compat-6.5.1-1.fc38.x86_64 from updates-testing requires libQt6Gui.so.6(Qt_6.5.1_PRIVATE_API)(64bit), but none of the providers can be installed - cannot install the best update candidate for package qt6-qt5compat-6.5.0-1.fc38.x86_64 Problem 5: problem with installed package QXlsx-1.4.6-1.fc38.x86_64 - package QXlsx-1.4.6-1.fc38.x86_64 from @System requires libQt6Gui.so.6(Qt_6_PRIVATE_API)(64bit), but none of the providers can be installed - package QXlsx-1.4.6-1.fc38.x86_64 from updates requires libQt6Gui.so.6(Qt_6_PRIVATE_API)(64bit), but none of the providers can be installed - package qt6-qtbase-gui-6.5.0-2.fc38.x86_64 from @System requires libQt6Core.so.6(Qt_6_PRIVATE_API)(64bit), but none of the providers can be installed - package qt6-qtbase-gui-6.5.0-2.fc38.x86_64 from updates requires libQt6Core.so.6(Qt_6_PRIVATE_API)(64bit), but none of the providers can be installed - package qt6-qtbase-gui-6.4.3-1.fc38.x86_64 from fedora requires qt6-qtbase(x86-64) = 6.4.3-1.fc38, but none of the providers can be installed - cannot install both qt6-qtbase-6.5.1-1.fc38.x86_64 from updates-testing and qt6-qtbase-6.5.0-2.fc38.x86_64 from @System - cannot install both qt6-qtbase-6.5.1-1.fc38.x86_64 from updates-testing and qt6-qtbase-6.4.3-1.fc38.x86_64 from fedora - cannot install both qt6-qtbase-6.5.1-1.fc38.x86_64 from updates-testing and qt6-qtbase-6.5.0-2.fc38.x86_64 from updates - cannot install the best update candidate for package qt6-qtbase-6.5.0-2.fc38.x86_64 Problem 6: problem with installed package stellarium-1.2-9.fc38.x86_64 - package stellarium-1.2-9.fc38.x86_64 from @System requires libQt6Gui.so.6(Qt_6_PRIVATE_API)(64bit), but none of the providers can be installed - package stellarium-1.2-9.fc38.x86_64 from fedora requires libQt6Gui.so.6(Qt_6_PRIVATE_API)(64bit), but none of the providers can be installed - package stellarium-1.2-9.fc38.x86_64 from updates-testing requires libQt6Gui.so.6(Qt_6_PRIVATE_API)(64bit), but none of the providers can be installed - cannot install both qt6-qtbase-gui-6.5.1-1.fc38.x86_64 from updates-testing and qt6-qtbase-gui-6.5.0-2.fc38.x86_64 from @System - cannot install both qt6-qtbase-gui-6.5.1-1.fc38.x86_64 from updates-testing and qt6-qtbase-gui-6.4.3-1.fc38.x86_64 from fedora - cannot install both qt6-qtbase-gui-6.5.1-1.fc38.x86_64 from updates-testing and qt6-qtbase-gui-6.5.0-2.fc38.x86_64 from updates - package qt6-qtdeclarative-6.5.1-1.fc38.x86_64 from updates-testing requires libQt6Gui.so.6(Qt_6.5.1_PRIVATE_API)(64bit), but none of the providers can be installed - package qt6-qtdeclarative-6.5.1-1.fc38.x86_64 from updates-testing requires libQt6Widgets.so.6(Qt_6.5.1_PRIVATE_API)(64bit), but none of the providers can be installed - package qt6-qtdeclarative-6.5.1-1.fc38.x86_64 from updates-testing requires libQt6OpenGL.so.6(Qt_6.5.1_PRIVATE_API)(64bit), but none of the providers can be installed - cannot install the best update candidate for package qt6-qtdeclarative-6.5.0-1.fc38.x86_64

User Icon rai510 provided feedback 11 months ago
karma
User Icon phantomx provided feedback 11 months ago
karma
User Icon besser82 commented & provided feedback 11 months ago
karma

Works great! LGTM! =)

jgrulich edited this update.

New build(s):

  • QXlsx-1.4.6-2.fc38
  • qt6ct-0.8-3.fc38
  • qcoro-0.9.0-2.fc38

Karma has been reset.

11 months ago

This update has been submitted for testing by jgrulich.

11 months ago

This update has been pushed to testing.

11 months ago

jgrulich edited this update.

New build(s):

  • obs-studio-29.1.1-2.fc38

Karma has been reset.

11 months ago

This update has been submitted for testing by jgrulich.

11 months ago

This update has obsoleted obs-studio-29.1.1-1.fc38, and has inherited its bugs and notes.

11 months ago

jgrulich edited this update.

New build(s):

  • python-pyqt6-charts-6.5.0-2.fc38

Karma has been reset.

11 months ago
karma

ngompa edited this update.

New build(s):

  • obs-studio-29.1.2-1.fc38

Removed build(s):

  • obs-studio-29.1.1-2.fc38

Karma has been reset.

11 months ago

This update has been pushed to testing.

11 months ago

jgrulich edited this update.

New build(s):

  • stellarium-1.2-10.fc38
  • QXlsx-1.4.6-3.fc38

Removed build(s):

  • QXlsx-1.4.6-2.fc38

Karma has been reset.

11 months ago

This update has been submitted for testing by jgrulich.

11 months ago

limb edited this update.

11 months ago
User Icon xvitaly commented & provided feedback 11 months ago
karma

LGTM.

User Icon ngompa provided feedback 11 months ago
karma
BZ#2196703 obs-studio-29.1.1 is available
BZ#2210802 obs-studio should be rebuilded with qt 6.5.1
BZ#2210885 obs-studio-29.1.2 is available
BZ#2211483 stellarium prevents qt6 upgrade

This update has been submitted for stable by bodhi.

11 months ago

This update has been pushed to stable.

10 months ago

Please login to add feedback.

BZ#2196703 obs-studio-29.1.1 is available
0
1
BZ#2210802 obs-studio should be rebuilded with qt 6.5.1
0
1
BZ#2210885 obs-studio-29.1.2 is available
0
1
BZ#2211483 stellarium prevents qt6 upgrade
0
1

Automated Test Results