FEDORA-EPEL-2011-3417

security update in Fedora EPEL 6 for drupal7

Status: stable 8 years ago
  • Advisory ID: DRUPAL-SA-CORE-2011-001
  • Project: Drupal core [1]
  • Version: 6.x, 7.x
  • Date: 2011-May-25
  • Security risk: Critical [2]
  • Exploitable from: Remote
  • Vulnerability: Access bypass, Cross Site Scripting

-------- DESCRIPTION

Multiple vulnerabilities and weaknesses were discovered in Drupal.

.... Reflected cross site scripting vulnerability in error handler

A reflected cross site scripting vulnerability was discovered in Drupal's error handler. Drupal displays PHP errors in the messages area, and a specially crafted URL can cause malicious scripts to be injected into the message. The issue can be mitigated by disabling on-screen error display at admin/settings/error-reporting. This is the recommended setting for production sites.

This issue affects Drupal 6.x only.

.... Cross site scripting vulnerability in Color module

When using re-colorable themes, color inputs are not sanitized. Malicious color values can be used to insert arbitrary CSS and script code. Successful exploitation requires the "Administer themes" permission.

This issue affects Drupal 6.x and 7.x.

.... Access bypass in File module

When using private files in combination with a node access module, the File module allows unrestricted access to private files.

This issue affects Drupal 7.x only.

-------- VERSIONS AFFECTED

  • Drupal 7.x before version 7.1.
  • Drupal 6.x before version 6.21.

-------- SOLUTION

Install the latest version:

  • If you are running Drupal 7.x then upgrade to Drupal 7.1 [3] or 7.2 [4].
  • If you are running Drupal 6.x then upgrade to Drupal 6.21 [5] or 6.22. [6]

The Security Team has released both a pure security update without other bug fixes and a security update combined with other bug fixes and improvements. You can choose to either only include the security update for an immediate fix (which might require less quality assurance and testing) or more fixes and improvements alongside the security fixes by choosing between Drupal 7.1 [7] and Drupal 7.2 [8] or Drupal 6.21 [9] and Drupal 6.22 [10].

See the release announcement [11] for more information.

See also the Drupal core [12] project page.

-------- REPORTED BY

  • The reflected cross site scripting vulnerability was reported by Heine Deelstra [13] (*).
  • The Color module cross site scripting vulnerability was reported by Kasper Lindgaard, Secunia Research.
  • The File access bypass was reported by Hubert Lecorche, and Peter Bex [14].

-------- FIXED BY

  • The reflected cross site scripting vulnerability was fixed by Alan Smithee.
  • The Color module cross site scripting vulnerability was fixed by St├ęphane Corlosquet [15] (), Heine Deelstra [16] (), and Peter Wolanin [17] (*).
  • The File access bypass was fixed by Heine Deelstra [18] (*).

(*) Member of the Drupal security team.

-------- CONTACT AND MORE INFORMATION

The Drupal security team can be reached at security at drupal.org or via the contact form at http://drupal.org/contact [19].

Learn more about the Drupal Security team and their policies [20], writing secure code for Drupal [21], and securing your site [22].

[1] http://drupal.org/project/drupal [2] http://drupal.org/security-team/risk-levels [3] http://drupal.org/node/1168910 [4] http://drupal.org/node/1168946 [5] http://drupal.org/node/1168908 [6] http://drupal.org/node/1168950 [7] http://drupal.org/node/1168910 [8] http://drupal.org/node/1168946 [9] http://drupal.org/node/1168908 [10] http://drupal.org/node/1168950 [11] http://drupal.org/drupal-7.2 [12] http://drupal.org/project/drupal [13] http://drupal.org/user/17943 [14] https://drupal.org/user/309898 [15] http://drupal.org/user/52142 [16] http://drupal.org/user/17943 [17] http://drupal.org/user/49851 [18] http://drupal.org/user/17943 [19] http://drupal.org/contact [20] http://drupal.org/security-team [21] http://drupal.org/writing-secure-code [22] http://drupal.org/security/secure-configuration


Security-news mailing list Security-news@drupal.org http://lists.drupal.org/mailman/listinfo/security-news

Require php 5.3.

Comments 5

This update has been submitted for testing by limb.

This update has been pushed to testing

This update has reached 14 days in testing and can be pushed to stable now if the maintainer wishes

This update has been submitted for stable by limb.

This update has been pushed to stable

Add Comment & Feedback

Please login to add feedback.

Content Type
RPM
Status
stable
Test Gating
Submitted by
Update Type
security
Update Severity
unspecified
Karma
0
stable threshold: 3
unstable threshold: -3
Autopush (karma)
Disabled
Autopush (time)
Disabled
Dates
submitted 8 years ago
in testing 8 years ago
in stable 8 years ago

Related Bugs 1

00 #704319 drupal7 should require php53 instead of php (including php sub-packages)

Automated Test Results