stable

uwsgi-2.0.11.2-7.el6

FEDORA-EPEL-2015-f0a06d1ee0 created by kad 8 years ago for Fedora EPEL 6

Fixes daemonization issue in el6 and provides uwsgi python decorators


With latest stable

This update has been submitted for testing by kad.

8 years ago

This update has obsoleted uwsgi-2.0.11.2-1.el6, and has inherited its bugs and notes.

8 years ago

This update has been pushed to testing.

8 years ago
User Icon avij commented & provided feedback 8 years ago

uwsgi-devel requires perl(Plack::Util), which is not available.

User Icon kad commented & provided feedback 8 years ago

@avij that's interesting, the only things included in -devel are uwsgi.h and a copy of the source the package was built with, no dependencies are added, is this a case of depsolv being overzealous?

User Icon avij commented & provided feedback 8 years ago

I have no idea why it requires perl(Plack::Util), but you can easily confirm this by fetching the uwsgi-devel package and then running rpm -qp uwsgi-devel-2.0.11.2-7.el6.x86_64.rpm --requires. You will notice that the devel package requires perl(HTTP::Status), perl(IO::Socket::INET), perl(Plack::Util), perl(strict), perl(warnings), uwsgi and some rpm libraries. Perhaps these are mentioned in the spec file.

This update has reached 14 days in testing and can be pushed to stable now if the maintainer wishes

8 years ago

This update has been submitted for stable by kad.

8 years ago
User Icon piotrp commented & provided feedback 8 years ago
karma

This is most likely caused by the auto_require_provides script which scans the source files to automatically add requires. One of the plugins loads the perl module, that is why it is added. You will need to add a filter: https://fedoraproject.org/wiki/EPEL:Packaging_Autoprovides_and_Requires_Filtering#Preventing_files.2Fdirectories_from_being_scanned_for_provides_.28pre-scan_filtering.29

User Icon kad commented & provided feedback 8 years ago

Thanks @piotrp that's exactly what I was looking for, doing that right now.

User Icon kad commented & provided feedback 8 years ago

Thanks @piotrp that's exactly what I was looking for, doing that right now.

This update has been pushed to stable.

8 years ago
User Icon kad commented & provided feedback 8 years ago

Unsure if you get notifications from the other update but just in case: FEDORA-EPEL-2016-a44ab91f78


Please login to add feedback.

Metadata
Type
bugfix
Karma
-1
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
3
Stable by Time
disabled
Dates
submitted
8 years ago
in testing
8 years ago
in stable
8 years ago
BZ#1258388 needs-packaging: uwsgi components are packaged in epel, but missing uwsgidecorators.
0
0
BZ#1261942 uwsgi should be daemonized on old SysV
0
0

Automated Test Results