Bump to upstream e6294e63a06b2be522ff3d328d8cacded0b1bd31


Polish the spec file


Polish spec file, enable devel and unit-test for epel7

This update has been submitted for testing by jchaloup.

3 years ago

This update has obsoleted golang-googlecode-google-api-client-0-0.16.git18450f4.el7, and has inherited its bugs and notes.

3 years ago

This update has been pushed to testing.

3 years ago
User Icon anonymous commented & provided feedback 3 years ago

package: golang-googlecode-google-api-client-unit-test-0-0.16.git18450f4.el7.x86_64

unresolved deps:

 golang-google-golang-api-devel = 0:0-0.16.git18450f4.el7

Wrong dependency?

karma: -1

User Icon anonymous commented & provided feedback 3 years ago

Actually that was another error. There was two builds with same 0.16 release number.

This update has reached 14 days in testing and can be pushed to stable now if the maintainer wishes

3 years ago
User Icon carlwgeorge commented & provided feedback 2 years ago
karma

This is not installable.

# yum --enablerepo epel-testing install golang-google-golang-api-devel
Loaded plugins: ovl
epel-testing                                                                                                                  | 4.7 kB  00:00:00     
(1/3): epel-testing/x86_64/updateinfo                                                                                         |  69 kB  00:00:00     
(2/3): epel-testing/x86_64/primary_db                                                                                         | 475 kB  00:00:00     
(3/3): epel-testing/x86_64/group_gz                                                                                           | 266 kB  00:00:00     
Resolving Dependencies
--> Running transaction check
---> Package golang-google-golang-api-devel.noarch 0:0-0.16.gite6294e6.el7 will be installed
--> Processing Dependency: golang(golang.org/x/net/context) for package: golang-google-golang-api-devel-0-0.16.gite6294e6.el7.noarch
--> Processing Dependency: golang(golang.org/x/net/context/ctxhttp) for package: golang-google-golang-api-devel-0-0.16.gite6294e6.el7.noarch
--> Finished Dependency Resolution
Error: Package: golang-google-golang-api-devel-0-0.16.gite6294e6.el7.noarch (epel-testing)
           Requires: golang(golang.org/x/net/context)
Error: Package: golang-google-golang-api-devel-0-0.16.gite6294e6.el7.noarch (epel-testing)
           Requires: golang(golang.org/x/net/context/ctxhttp)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Bodhi is disabling automatic push to stable due to negative karma. The maintainer may push manually if they determine that the issue is not severe.

2 years ago

Can someone sort this out and push a new build? I'd like to build require it in one of my packages.

I would love to but we are still stuck on https://bugzilla.redhat.com/show_bug.cgi?id=1409553. Otherwise we violate the Fedora packaging guidelines cause some Golang packages are already in RHEL and we can not update them in epel7.

User Icon carlwgeorge commented & provided feedback a year ago
karma

Golang is deprecated in RHEL, and thus has been added back to EPEL. This update is now installable. Would anyone mind if I pushed it to stable?

This update's test gating status has been changed to 'greenwave_failed'.

8 months ago

This update's test gating status has been changed to 'ignored'.

8 months ago

This update's test gating status has been changed to 'greenwave_failed'.

2 months ago

This update's test gating status has been changed to 'ignored'.

2 months ago

This update's test gating status has been changed to 'greenwave_failed'.

4 days ago

This update's test gating status has been changed to 'ignored'.

4 days ago

Please login to add feedback.

Metadata
Type
enhancement
Karma
1
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Dates
submitted
3 years ago
in testing
3 years ago
BZ#1250521 Tracker for golang-googlecode-google-api-client
0
0

Automated Test Results