FEDORA-EPEL-2016-d398cc4c6c

security update in Fedora EPEL 7 for roundcubemail

Status: stable 3 years ago

Release 1.1.5

  • Plugin API: Added html2text hook
  • Plugin API: Added addressbook_export hook
  • Fix missing emoticons on html-to-text conversion
  • Fix random "access to this resource is secured against CSRF" message at logout (#4956)
  • Fix missing language name in "Add to Dictionary" request in HTML mode (#4951)
  • Enable use of TLSv1.1 and TLSv1.2 for IMAP (#4955)
  • Fix XSS issue in SVG images handling (#4949)
  • Fix (again) security issue in DBMail driver of password plugin (CVE-2015-2181) (#4958)
  • Fix bug in long recipients list parsing for cases where recipient name contained @-char (#4964)
  • Fix additional_message_headers plugin compatibility with Mail_Mime >= 1.9 (#4966)
  • Hide DSN option in Preferences when smtp_server is not used (#4967)
  • Protect download urls against CSRF using unique request tokens (#4957)
  • newmail_notifier Plugin: Refactored desktop notifications
  • Fix so contactlist_fields option can be set via config file
  • Fix so SPECIAL-USE assignments are forced only until user sets special folders (#4782)
  • Fix performance in reverting order of THREAD result
  • Fix converting mail addresses with www. into mailto links (#5197)

Comments 6

This update has been submitted for testing by remi.

This update has been pushed to testing.

remi edited this update.

This update has reached 14 days in testing and can be pushed to stable now if the maintainer wishes

This update has been submitted for stable by remi.

This update has been pushed to stable.

Add Comment & Feedback

Please login to add feedback.

Content Type
RPM
Status
stable
Test Gating
Submitted by
Update Type
security
Update Severity
unspecified
Karma
0
stable threshold: 3
unstable threshold: -3
Autopush (karma)
Enabled
Autopush (time)
Disabled
Dates
submitted 3 years ago
in testing 3 years ago
in stable 3 years ago
modified 3 years ago

Related Bugs 2

00 #1330084 CVE-2015-2181 CVE-2015-8864 CVE-2016-4068 CVE-2016-4069 roundcubemail: security issues fixed in version 1.0.9
00 #1330086 CVE-2015-2181 CVE-2015-8864 CVE-2016-4068 CVE-2016-4069 roundcubemail: security issues fixed in version 1.0.9 [epel-all]

Automated Test Results