Update pugixml to latest version for new package review and rebuild dependencies.

This update has been submitted for testing by hobbes1069.

4 years ago

This update has obsoleted gfal2-2.12.2-1.el7, and has inherited its bugs and notes.

4 years ago

This update has been pushed to testing.

4 years ago
User Icon anonymous commented & provided feedback 4 years ago

OpenImageIO also uses libpugixml and .so version bump requires adding it to this update.

package: OpenImageIO-1.4.16-1.el7.x86_64

unresolved deps:

 libpugixml.so.1.0()(64bit)

package: OpenImageIO-iv-1.4.16-1.el7.x86_64

unresolved deps:

 libpugixml.so.1.0()(64bit)

karma: -1

hobbes1069 edited this update.

New build(s):

  • OpenImageIO-1.5.24-3.el7
4 years ago

This update has been submitted for testing by hobbes1069.

4 years ago
User Icon hobbes1069 commented & provided feedback 4 years ago

Thanks for the catch!

User Icon germano provided feedback 4 years ago
karma

This update has been pushed to testing.

4 years ago
User Icon anonymous commented & provided feedback 4 years ago

Well- Deps of the deps are still missing...

package: OpenColorIO-tools-1.0.9-3.el7.x86_64

unresolved deps:

 libOpenImageIO.so.1.4()(64bit)

So OpenImageIO was updated to new version causing again another .so version bump. Now OpenColorIO-tools require update.

User Icon anonymous commented & provided feedback 4 years ago

I rebuilt OpenColorIO from epel7 branch locally for testing and that fixes rest of the dependency problems.

User Icon anonymous commented & provided feedback 4 years ago

I rebuilt OpenColorIO from epel7 branch locally for testing and that fixes rest of the dependency problems.

User Icon hobbes1069 commented & provided feedback 4 years ago

Yes, that's what I was trying to do but it failed to build because when OpenImageIO is being installed to the buildroot it errors out:

Error: Package: OpenImageIO-1.5.24-3.el7.x86_64 (build) Requires: libpugixml.so.1()(64bit)

But as far as I can tell OpenImageIO was built with the new version of pugixml AND there's a buildroot override for it.

User Icon hobbes1069 commented & provided feedback 4 years ago

Looks like bodhi was lying to me. It says the buildroot override is active but when I look in koji there's no epel7-override tag.

hobbes1069 edited this update.

New build(s):

  • OpenColorIO-1.0.9-4.el7
4 years ago

This update has been submitted for testing by hobbes1069.

4 years ago

This update has been pushed to testing.

4 years ago

This update has reached 14 days in testing and can be pushed to stable now if the maintainer wishes

4 years ago

This update has been submitted for stable by hobbes1069.

4 years ago

This update has been pushed to stable.

4 years ago

Please login to add feedback.

Metadata
Type
enhancement
Severity
low
Karma
0
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
3
Stable by Time
disabled
Dates
submitted
4 years ago
in testing
4 years ago
in stable
4 years ago
modified
4 years ago

Automated Test Results