Highlight

  • Read Koji configuration from profile.
  • fedpkg-stage is usable
  • Non-zero is returned when local command fails
  • More Python 3 compatible
  • Allow container builds from any namespace
  • Supply namespace to lookaside (if enabled)

UPDATED:

Please test command container-build.

rpkg

  • Fix PEP8 error (cqi)
  • Spelling fixes (ville.skytta)
  • Reword help and description of new-sources and upload commands - 1248737 (cqi)
  • Set autorebuild enabled by default (bfontecc)
  • Add commands to whitelist_externals (cqi)
  • Declare Python 3 versions to support in setup.py (cqi)
  • Replace unicode with six.text_type (cqi)
  • Run tests in both Python 2 and 3 with tox (cqi)
  • Make tests and covered code compatible with Py3 (cqi)
  • Add requirements files (cqi)
  • Do not build srpm in test (cqi)
  • Do not actually run git-diff in tests (cqi)
  • Remove deprecated modules used in koji (cqi)
  • Non-zero exit when rpmbuild fails in local command (cqi)
  • Report deprecation of config via logger (lsedlar)
  • Print --dist deprecation warning explicitly (lsedlar)
  • utils: Avoid DeprecationWarning for messages for users (lsedlar)
  • Supply namespace to lookaside (if enabled) (lsedlar)
  • Support reading koji config from profile - #187 (cqi)
  • Remove kitchen (cqi)
  • Fix string format (cqi)
  • Recommend --release instead of --dist in mockbuild --help (tmz)
  • Allow overriding container build target by downstream (lsedlar)
  • Add a separate property for namespace (lsedlar)
  • Allow container builds from any namespace (maxamillion)
  • Make osbs support optional (cqi)
  • make osbs dependency optional (pavlix)
  • Allow explicit namespaces with slashes (lsedlar)
  • Do not hang indefinitely when lookaside cache server stops sending data (jkaluza)
  • Make --module-name work with namespaces - #216 (lsedlar)
  • Include README.rst in dist package (cqi)
  • More document in README - #189 (cqi)
  • Make new command be able to print unicode - #205 (cqi)
  • Allow to specify custom info to a dummy commit (cqi)
  • Load module name correctly even if push url ends in slash - #192 (cqi)
  • Replace fedorahosted.org with pagure.io - #202 (cqi)
  • Fix rpm command to get changelog from SPEC - #1412224 (cqi)
  • Rewrite tests to avoid running rpmbuild and rpmlint (cqi)
  • Use fake value to make Command in test (cqi)
  • Python 3.6 invalid escape sequence deprecation fixes (ville.skytta)

fedpkg

  • Remove unused variable in Commands.retire (cqi)
  • No more pkgdb. (rbean)
  • Add --arches to build completions (ville.skytta)
  • Add ppc64le to arch completions (ville.skytta)
  • Explain how to write a note in multiple lines in update template - #123 (cqi)
  • Remove code that handles secondary arch (cqi)
  • Simplify passing arguments when creating Command object - #14 (cqi)
  • Set koji profile for secondary arch immediately (cqi)
  • Use profile to load Koji configuration - #97 (cqi)
  • Remove push.default from clone_default - #109 (cqi)
  • remove special handling of s390 specific packages (dan)
  • Replace fedorahosted.org with pagure.io in manpage - #113 (cqi)
  • Remove tracbaseurl from conf file - #112 (cqi)
  • Set disttag properly (cqi)
  • koji stage config moved, update fedpkg defaults (maxamillion)
  • Specific help of --release for fedpkg - #1054440 (cqi)

This update has been submitted for testing by cqi.

2 years ago

This update has been pushed to testing.

2 years ago

cqi edited this update.

New build(s):

  • fedpkg-1.29-2.el7

Removed build(s):

  • fedpkg-1.29-1.el7

Karma has been reset.

2 years ago

This update has been submitted for testing by cqi.

2 years ago

This update has been pushed to testing.

2 years ago
User Icon chr77 commented & provided feedback 2 years ago
karma

Works for me. No regressions noted compared to previous version.

cqi edited this update.

New build(s):

  • fedpkg-1.29-3.el7
  • rpkg-1.50-2.el7

Removed build(s):

  • fedpkg-1.29-2.el7
  • rpkg-1.50-1.el7

Karma has been reset.

2 years ago

This update has been submitted for testing by cqi.

2 years ago

This update has been pushed to testing.

2 years ago
User Icon anonymous commented & provided feedback 2 years ago

There is a typo in fedpkg-stage requirements:

package: fedpkg-stage-1.29-3.el7.noarch

unresolved deps:

 fedpkg = 0:1.29.3.el7

I guess that's easy to see from repoclosure error...

User Icon cqi commented & provided feedback 2 years ago

Fix is under review now, and new package will be updated here soon.

This update has been unpushed.

This update has been submitted for testing by cqi.

2 years ago

This update has been pushed to testing.

2 years ago

This update has reached 14 days in testing and can be pushed to stable now if the maintainer wishes

2 years ago

This update has been submitted for stable by cqi.

2 years ago

This update has been pushed to stable.

2 years ago

Please login to add feedback.

Metadata
Type
enhancement
Karma
0
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
3
Dates
submitted
2 years ago
in testing
2 years ago
in stable
2 years ago
modified
2 years ago
BZ#1248737 What is the difference between new-sources and upload?
0
0
BZ#1410300 "fedpkg local" should return nonzero exitcode when build fails
0
0
BZ#1412224 fedpkg update fails: Could not execute update: error: Unable to open /home/jsynacek/rpmbuild/SOURCES/triggers.systemd: No such file or directory
0
0
BZ#1487383 cannot do build
0
0

Automated Test Results

Test Cases

0 0 Test Case build from distgit with mock
0 0 Test Case clone distgit repository
0 0 Test Case download upstream sources
0 0 Test Case scratch build from distgit