FEDORA-EPEL-2017-3da5d4f25f created by dsommers 4 years ago for Fedora EPEL 6
stable

Updating to upstream OpenVPN v2.4.1. This update re-introduces a DEPRECATED feature to, --tls-remote to enable v2.3 installations to upgrade. Users are STRONGLY encouraged to update their configurations to use the newer option, --verify-x509-name. In addition the general packaging have been cleaned up.

This update has been submitted for testing by dsommers.

4 years ago

dsommers edited this update.

New build(s):

  • openvpn-2.4.1-2.el6

Removed build(s):

  • openvpn-2.4.1-1.el6
4 years ago

This update has been pushed to testing.

4 years ago

dsommers edited this update.

New build(s):

  • openvpn-2.4.1-3.el6

Removed build(s):

  • openvpn-2.4.1-2.el6
4 years ago

This update has been submitted for testing by dsommers.

4 years ago

dsommers edited this update.

4 years ago

This update has been pushed to testing.

4 years ago

This update has reached 14 days in testing and can be pushed to stable now if the maintainer wishes

4 years ago
User Icon dsommers commented & provided feedback 4 years ago

I've run openvpn-2.4.1-2.el6 on a SL6.7 since March 23 and 2.4.1-3.el6 since April 10. Both configured with server and client configurations. Everything works as expected in those configurations. The 2.4 release have otherwise been pushed out for el7, where the main difference is that el7 is systemd based and el6 still uses init.d scripts. So considering this to be reasonably safe.

This update has been submitted for stable by dsommers.

4 years ago

This update has been pushed to stable.

4 years ago
User Icon anonymous commented & provided feedback 4 years ago

Hi Guys, /var/run/openvpn/ is missing in rpm-File: rpm -ql openvpn /etc/openvpn /etc/openvpn/client /etc/openvpn/server /usr/lib/systemd/system/openvpn-client@.service /usr/lib/systemd/system/openvpn-server@.service /usr/lib/systemd/system/openvpn@.service /usr/lib/tmpfiles.d/openvpn.conf /usr/lib64/openvpn /usr/lib64/openvpn/plugins /usr/lib64/openvpn/plugins/openvpn-plugin-auth-pam.so /usr/lib64/openvpn/plugins/openvpn-plugin-down-root.so /usr/sbin/openvpn /usr/share/doc/openvpn-2.4.1 /usr/share/doc/openvpn-2.4.1/AUTHORS /usr/share/doc/openvpn-2.4.1/COPYING /usr/share/doc/openvpn-2.4.1/COPYRIGHT.GPL /usr/share/doc/openvpn-2.4.1/Changes.rst /usr/share/doc/openvpn-2.4.1/README /usr/share/doc/openvpn-2.4.1/README.auth-pam /usr/share/doc/openvpn-2.4.1/README.down-root /usr/share/doc/openvpn-2.4.1/README.systemd /usr/share/doc/openvpn-2.4.1/contrib /usr/share/doc/openvpn-2.4.1/contrib/OCSP_check /usr/share/doc/openvpn-2.4.1/contrib/OCSP_check/OCSP_check.sh /usr/share/doc/openvpn-2.4.1/contrib/README /usr/share/doc/openvpn-2.4.1/contrib/openvpn-fwmarkroute-1.00 /usr/share/doc/openvpn-2.4.1/contrib/openvpn-fwmarkroute-1.00/README /usr/share/doc/openvpn-2.4.1/contrib/openvpn-fwmarkroute-1.00/fwmarkroute.down /usr/share/doc/openvpn-2.4.1/contrib/openvpn-fwmarkroute-1.00/fwmarkroute.up /usr/share/doc/openvpn-2.4.1/contrib/pull-resolv-conf /usr/share/doc/openvpn-2.4.1/contrib/pull-resolv-conf/client.down /usr/share/doc/openvpn-2.4.1/contrib/pull-resolv-conf/client.up /usr/share/doc/openvpn-2.4.1/management-notes.txt /usr/share/doc/openvpn-2.4.1/sample /usr/share/doc/openvpn-2.4.1/sample/sample-config-files /usr/share/doc/openvpn-2.4.1/sample/sample-config-files/README /usr/share/doc/openvpn-2.4.1/sample/sample-config-files/client.conf /usr/share/doc/openvpn-2.4.1/sample/sample-config-files/firewall.sh /usr/share/doc/openvpn-2.4.1/sample/sample-config-files/home.up /usr/share/doc/openvpn-2.4.1/sample/sample-config-files/loopback-client /usr/share/doc/openvpn-2.4.1/sample/sample-config-files/loopback-server /usr/share/doc/openvpn-2.4.1/sample/sample-config-files/office.up /usr/share/doc/openvpn-2.4.1/sample/sample-config-files/openvpn-shutdown.sh /usr/share/doc/openvpn-2.4.1/sample/sample-config-files/openvpn-startup.sh /usr/share/doc/openvpn-2.4.1/sample/sample-config-files/roadwarrior-client.conf /usr/share/doc/openvpn-2.4.1/sample/sample-config-files/roadwarrior-server.conf /usr/share/doc/openvpn-2.4.1/sample/sample-config-files/server.conf /usr/share/doc/openvpn-2.4.1/sample/sample-config-files/static-home.conf /usr/share/doc/openvpn-2.4.1/sample/sample-config-files/static-office.conf /usr/share/doc/openvpn-2.4.1/sample/sample-config-files/tls-home.conf /usr/share/doc/openvpn-2.4.1/sample/sample-config-files/tls-office.conf /usr/share/doc/openvpn-2.4.1/sample/sample-config-files/xinetd-client-config /usr/share/doc/openvpn-2.4.1/sample/sample-config-files/xinetd-server-config /usr/share/doc/openvpn-2.4.1/sample/sample-scripts /usr/share/doc/openvpn-2.4.1/sample/sample-scripts/auth-pam.pl /usr/share/doc/openvpn-2.4.1/sample/sample-scripts/bridge-start /usr/share/doc/openvpn-2.4.1/sample/sample-scripts/bridge-stop /usr/share/doc/openvpn-2.4.1/sample/sample-scripts/ucn.pl /usr/share/doc/openvpn-2.4.1/sample/sample-scripts/verify-cn /usr/share/doc/openvpn-2.4.1/sample/sample-windows /usr/share/doc/openvpn-2.4.1/sample/sample-windows/sample.ovpn /usr/share/man/man8/openvpn.8.gz

So openvpn is unable to create its pidfile. Altough openvpn-client still can start. There is also a report on this here: https://bugzilla.redhat.com/show_bug.cgi?id=1435036#c15

User Icon dsommers commented & provided feedback 4 years ago

Please test a far newer OpenVPN release. This release is obsolete. OpenVPN 2.4.3 was put submitted 5 days ago.

$ rpm -ql openvpn | grep run
/var/run/openvpn
$ rpm -q openvpn
openvpn-2.4.3-1.el6.x86_64

This should not be an issue at all. You can find it here: FEDORA-EPEL-2017-9ec615ff74

Btw. the bz you reference is also an invalid reference. That is related to Fedora 26, which relies on systemd and its tmpfiles service. That does not exist on EL6.

User Icon dsommers commented & provided feedback 4 years ago

Sorry, a little clarification. That bz comment you reference, is related to a Fedora release with systemd.

User Icon anonymous commented & provided feedback 4 years ago

@dsommers: as you told here https://bodhi.fedoraproject.org/updates/openvpn-2.4.1-2.el7#comment-588424 this is a feature on EL7. This package here only affects EL6

User Icon dsommers commented & provided feedback 4 years ago

That is right. The tmpfiles.d stuff is related to systemd, which is EL7 and any Fedora releases after 17 or so. And /var/run/openvpn is packaged properly in openvpn-2.4.2 and openvpn-2.4.3, so this is no longer an issue. The openvpn-2.4.1 package this update is about, is obsolete and outdated.


Please login to add feedback.

Metadata
Type
enhancement
Severity
medium
Karma
0
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-1
Stable by Karma
2
Stable by Time
disabled
Dates
submitted
4 years ago
in testing
4 years ago
in stable
4 years ago
modified
4 years ago
BZ#1435036 openvpn-2.4.1 is available
0
0

Automated Test Results