FEDORA-EPEL-2017-650d7b9356

security update in Fedora EPEL 7 for bodhi, python-fedora, & 1 more

Status: stable 5 months ago

This update set fixed problems with Bodhi update submitting.

It also includes two security fixes for python-fedora.


Update to 2.6.1.

Comments 9

This update has been submitted for testing by puiterwijk.

This update has obsoleted bodhi-2.6.1-1.el7, and has inherited its bugs and notes.

This update has been pushed to testing.

I was able to install the python-fedora package without the python-openidc-client package being automatically pulled in. Do we need a Requires: python-openidc-client in python-fedora?

This update has reached 14 days in testing and can be pushed to stable now if the maintainer wishes

Here is some yum output demonstrating this:

sudo yum update bodhi-client --enablerepo epel-testing
Loaded plugins: fastestmirror
epel-testing/x86_64/metalink                                                                                                                                                                                          |  15 kB  00:00:00     
epel-testing                                                                                                                                                                                                          | 4.3 kB  00:00:00     
(1/3): epel-testing/x86_64/updateinfo                                                                                                                                                                                 |  75 kB  00:00:00     
(2/3): epel-testing/x86_64/group_gz                                                                                                                                                                                   | 170 kB  00:00:00     
(3/3): epel-testing/x86_64/primary_db                                                                                                                                                                                 | 516 kB  00:00:00     
Loading mirror speeds from cached hostfile
 * base: mirror.5ninesolutions.com
 * epel: mirror.us.leaseweb.net
 * epel-testing: mirror.us.leaseweb.net
 * extras: mirror.5ninesolutions.com
 * updates: mirror.5ninesolutions.com
Resolving Dependencies
--> Running transaction check
---> Package bodhi-client.noarch 0:2.5.0-2.el7 will be updated
---> Package bodhi-client.noarch 0:2.6.2-1.el7 will be an update
--> Processing Dependency: python2-bodhi = 2.6.2-1.el7 for package: bodhi-client-2.6.2-1.el7.noarch
--> Processing Dependency: python-fedora >= 0.9 for package: bodhi-client-2.6.2-1.el7.noarch
--> Running transaction check
---> Package python-fedora.noarch 0:0.7.1-2.el7 will be updated
---> Package python-fedora.noarch 0:0.9.0-1.el7 will be an update
---> Package python2-bodhi.noarch 0:2.5.0-2.el7 will be updated
---> Package python2-bodhi.noarch 0:2.6.2-1.el7 will be an update
--> Finished Dependency Resolution

This update has been submitted for stable by puiterwijk.

This update has been pushed to stable.


Add Comment & Feedback
Toggle Preview

Comment fields support Fedora-Flavored Markdown.

-1 0 +1 Feedback Guidelines
#1445294 bodhi client cannot submit a new update
#1447149 bodhi-2.6.1 is available
Is the update generally functional?
Content Type
RPM
Status
stable
Submitted by
Update Type
security
Update Severity
urgent
Karma
+1
stable threshold: 3
unstable threshold: -3
Autopush
Enabled
Dates
submitted 5 months ago
in testing 5 months ago
in stable 5 months ago

Related Bugs 2

0+1 #1445294 bodhi client cannot submit a new update
0+1 #1447149 bodhi-2.6.1 is available

Automated Test Results