security update in Fedora EPEL 6 for moodle

Status: stable 2 years ago

Multiple CVE fixes.

Comments 10

This update has been submitted for testing by limb.

limb edited this update.

This update has been pushed to testing.

limb edited this update.

This update has reached 14 days in testing and can be pushed to stable now if the maintainer wishes

This update has been submitted for stable by limb.

This update has been pushed to stable.

moodle-2.7.19-1.el6 has been pushed to the Fedora EPEL 6 stable repository, but moodle 2.7.19 requires PHP 5.4.4 and Mysql 5.5.31 as shown here: https://docs.moodle.org/dev/Moodle_2.7_release_notes#Server_requirements

CentOS 6 (or EL 6 in general) has php-5.3.3 and mysql-5.1.73 and it's impossible to use moodle-2.7.19-1.el6 from EPEL 6.

At the end of normal istallation it's shows a blank page on browser instead to show the first steps of configuration.

The cron job of moodle (admin/cli/cron.php) returns this message: Moodle 2.7 or later requires at least PHP 5.4.4 (currently using version 5.3.3)

karma: -1

moodle-2.7.19-1.el6 has to be removed from EPEL-6, the last working version for EPEL-6 was moodle-2.6.11-3.el6.noarch. Please let that version again available.

karma: -1


If you can test and comment it will help get this out faster. Thanks!

Add Comment & Feedback

Please login to add feedback.

Content Type
Test Gating
Submitted by
Update Type
Update Severity
stable threshold: 3
unstable threshold: -3
Autopush (karma)
Autopush (time)
submitted 2 years ago
in testing 2 years ago
in stable 2 years ago
modified 2 years ago

Related Bugs 4

00 #1299361 CVE-2016-0724 moodle: two enrolment-related web services don't check course visibility [epel-6]
00 #1319681 CVE-2016-2151 CVE-2016-2152 CVE-2016-2153 CVE-2016-2154 CVE-2016-2155 CVE-2016-2156 CVE-2016-2157 CVE-2016-2158 CVE-2016-2159 CVE-2016-2190 moodle: multiple security issues fixed in 3.0.3, 2.9.5, 2.8.11, 2.7.13 [epel-6]
00 #1336730 CVE-2016-3729 CVE-2016-3731 CVE-2016-3732 CVE-2016-3733 CVE-2016-3734 moodle: Multiple vulnerabilities fixed in 3.0.4, 2.9.6, 2.8.12 and 2.7.14 [epel-all]
00 #1434721 CVE-2017-2641 CVE-2017-2643 CVE-2017-2644 CVE-2017-2645 moodle: Multiple security vulnerabilities [epel-7]

Automated Test Results