FEDORA-EPEL-2018-aeb81e4fba

security update in Fedora EPEL 6 for libpng10

Status: stable 10 months ago

Fix for CVE-2018-13785: the libpng10 library was vulnerable to an integer overflow and resultant divide-by-zero in the pngrutil.c:png_check_chunk_length() function. An attacker could exploit this to cause a denial of service via a crafted PNG file.

How to install

sudo dnf upgrade --advisory=FEDORA-EPEL-2018-aeb81e4fba

Comments 6

This update has been submitted for testing by pghmcfc.

This update has been pushed to testing.

This update has reached 14 days in testing and can be pushed to stable now if the maintainer wishes

This update has been submitted for batched by pghmcfc.

This update has been submitted for stable by bodhi.

This update has been pushed to stable.

Content Type
RPM
Status
stable
Test Gating
Submitted by
Update Type
security
Update Severity
low
Karma
0
stable threshold: 2
unstable threshold: -1
Autopush
Disabled
Dates
submitted 11 months ago
in testing 11 months ago
in stable 10 months ago

Related Bugs 2

00 #1599943 CVE-2018-13785 libpng: Integer overflow and resultant divide-by-zero in pngrutil.c:png_check_chunk_length() allows for denial of service
00 #1599950 CVE-2018-13785 libpng10: libpng: Integer overflow and resultant divide-by-zero in pngrutil.c:png_check_chunk_length() allows for denial of service [epel-6]

Automated Test Results