FEDORA-EPEL-2019-84c3d7529d created by denisarnaud 6 months ago for Fedora EPEL 7
obsolete

Update to upstream 4.0.0


Upgrade to 4.0.0-rc1

This update has been submitted for testing by denisarnaud.

6 months ago

This update's test gating status has been changed to 'waiting'.

6 months ago

This update has obsoleted soci-4.0.0-1.el7, and has inherited its bugs and notes.

6 months ago

This update's test gating status has been changed to 'ignored'.

6 months ago

This update has been pushed to testing.

6 months ago
User Icon tis commented & provided feedback 6 months ago
karma

First, this package has invalid dependencies:

package: soci-postgresql-devel-4.0.0-2.el7.x86_64

unresolved deps:

 libpq-devel

Package includes .so version bump which is only allowed if all dependencies are updated coordinated manner. Currently this breaks at least following packages:

travelccm-1.00.2-1.el7, trademgen-1.00.2-1.el7, simcrs-1.01.1-3.el7, simfqt-1.00.1-1.el7, sevmgr-1.00.2-1.el7, python3-opentrep-0.07.1-2.el7 (which btw is wrong package naming on epel7, should be python36-opentrep), opentrep-0.07.1-2.el7, airtsp-1.01.2-1.el7 and airinv-1.00.1-3.el7. I might have missed some.

Bodhi is disabling automatic push to stable due to negative karma. The maintainer may push manually if they determine that the issue is not severe.

6 months ago

Thanks! As a matter of fact, all the packages depending on SOCI are mine. So, the update would be coordinated :)

For the dependency on libpq-devel and the Python sub-package name, you are (of course) righ; thanks for that report!

Wrt the libpd-devel dependency, a filtering macro was missing. It has been added in https://koji.fedoraproject.org/koji/taskinfo?taskID=39208447 Will create a new update for it. Thanks!

This update has been obsoleted by soci-4.0.0-4.el7.

6 months ago

Please login to add feedback.

Metadata
Type
unspecified
Karma
-1
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Dates
submitted
6 months ago
in testing
6 months ago

Automated Test Results