Xfce 4.14 on EPEL8. Please add a comment on bodhi or open a bug report if I have missed any packages.

Fixed xfdesktop build.

Reboot Required
After installing this update it is required that you reboot your system to ensure the changes supplied by this update are applied properly.

This update has been submitted for testing by nonamedotc.

8 months ago

This update's test gating status has been changed to 'ignored'.

8 months ago

nonamedotc edited this update.

New build(s):

  • mousepad-0.4.2-1.el8

Karma has been reset.

8 months ago

This update has been pushed to testing.

8 months ago
User Icon akosprime commented & provided feedback 8 months ago

Haven't been able to get it to install. Tried something simple like this:

yum --enablerepo=epel-testing install xfdesktop

Last metadata expiration check: 0:06:46 ago on Wed 18 Dec 2019 04:01:46 PM UTC. Error: Problem: package xfdesktop-4.14.1-2.el8.x86_64 requires desktop-backgrounds-compat, but none of the providers can be installed - conflicting requests - nothing provides f31-backgrounds-base needed by desktop-backgrounds-compat-31.0.0-1.el8.noarch (try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

I didn't try the 'skip-broken' or 'nobest' options.

User Icon lory23 commented & provided feedback 8 months ago
karma

There's no group "Xfce" as there where on Epel 7. It could be very useful with minimal installation and with "base-x" group installed. Trying to: dnf --enablerepo=epel-testing install xfce4-* i get 2 problems. Problem 1: package xfce4-panel-devel-4.14.1.1-1.el8.x86_64 requires libxfce4ui-devel >= 4.14 but none of the providers can be installed - conflicting requests - nothing provides glade-devel needed by libxfce4ui-devel-4.14.1.1-1.el8.x86_64 Problem 2: package xfdesktop-4.14.1-2.el8.x86_64 requires desktop-backgrounds-compat, but none of the providers can be installed - conflicting requests - nothing provides f31-backgrounds-base needed by desktop-backgrounds-compat-31.0.0-1.el8.noarch

Then i stop the installation.

BZ#1744139 Request to build xfce for EPEL 8
User Icon nonamedotc commented & provided feedback 8 months ago
  • glade-devel needs to have Centos-PowerTools repo enabled.
  • I will fix xfdesktop.

Thanks for the feedback.

nonamedotc edited this update.

New build(s):

  • xfdesktop-4.14.1-3.el8

Removed build(s):

  • xfdesktop-4.14.1-2.el8

Karma has been reset.

8 months ago

This update has been submitted for testing by nonamedotc.

8 months ago

This update has been pushed to testing.

8 months ago
User Icon akosprime commented & provided feedback 8 months ago

Has xfdesktop 4.14.1-3.el8 been pushed to the epel-testing repository? I still only see 4.14.1-2.el8:

yum --enablerepo=epel-testing info xfdesktop

Last metadata expiration check: 0:02:04 ago on Fri 20 Dec 2019 12:25:29 PM UTC. Available Packages Name : xfdesktop Version : 4.14.1 Release : 2.el8 Arch : x86_64 Size : 1.2 M Source : xfdesktop-4.14.1-2.el8.src.rpm Repo : epel-testing Summary : Desktop manager for the Xfce Desktop Environment URL : http://www.xfce.org/ License : GPLv2+ Description : This package includes a desktop manager for the Xfce Desktop Environment.

This update can be pushed to stable now if the maintainer wishes

7 months ago

This update has been submitted for stable by nonamedotc.

7 months ago

This update has been pushed to stable.

7 months ago

Please login to add feedback.

BZ#1744139 Request to build xfce for EPEL 8
0
0

Automated Test Results