stable

libmodulemd2-2.8.0-2.el7

FEDORA-EPEL-2019-e093131fa7 created by sgallagh 4 years ago for Fedora EPEL 7

Highlights

API Changes

  • Add Modulemd.Module.get_translation() - Retrieve the translations associated with a Modulemd.Module
  • Add ModuleIndex.update_from_defaults_directory() - Import defaults from a directory of yaml documents, such as fedora-module-defaults, optionally providing a second path containing overrides.

Enhancements

  • Modulemd.ModuleIndex.update_from_file() now supports reading files compressed with gzip, bzip2 or xz. (Issue: #208). See "Packaging Changes" for additional details.
  • Documentation updates

Bugfixes

  • Assorted minor issues discovered by static analysis tools.
  • Don't conflict with /usr/bin/modulemd-validator

Packaging Changes

  • Now requires librpmio to enable compressed file support. If you do not have librpmio available on your platform, pass -Drpmio=disabled to the meson configuration step to disable it.
  • Now requires libmagic (part of the file package on most distributions) for enhanced auto-detection of compressed file support. If libmagic is unavailable, pass -Dmagic=disabled to the meson configuration step to disable it. Auto-detection will be limited to filename suffix if libmagic is unavailable.

This update has been submitted for testing by sgallagh.

4 years ago

This update's test gating status has been changed to 'waiting'.

4 years ago

This update's test gating status has been changed to 'ignored'.

4 years ago

This update has been pushed to testing.

4 years ago
User Icon mprahl commented & provided feedback 4 years ago
karma

This conflicts with the libmodulemd RPM included in RHEL. See the following error: file /usr/bin/modulemd-validator conflicts between attempted installs of libmodulemd2-2.8.0-1.el7.x86_64 and libmodulemd-1.6.3-1.el7.x86_64

Bodhi is disabling automatic push to stable due to negative karma. The maintainer may push manually if they determine that the issue is not severe.

4 years ago

sgallagh edited this update.

New build(s):

  • libmodulemd2-2.8.0-2.el7

Removed build(s):

  • libmodulemd2-2.8.0-1.el7

Karma has been reset.

4 years ago

This update has been submitted for testing by sgallagh.

4 years ago
User Icon mprahl commented & provided feedback 4 years ago
karma

The previous comment was resolved and all the MBS unit tests pass with this version of libmodulemd.

This update has been pushed to testing.

4 years ago

sgallagh edited this update.

4 years ago

This update can be pushed to stable now if the maintainer wishes

4 years ago
User Icon sgallagh provided feedback 4 years ago

This update has been submitted for stable by sgallagh.

4 years ago

This update has been pushed to stable.

4 years ago

Please login to add feedback.

Metadata
Type
enhancement
Severity
high
Karma
1
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
1
Stable by Time
14 days
Dates
submitted
4 years ago
in testing
4 years ago
in stable
4 years ago
modified
4 years ago

Automated Test Results