Mass updates

This update has been submitted for testing by sagitter.

7 months ago

This update's test gating status has been changed to 'waiting'.

7 months ago

This update's test gating status has been changed to 'ignored'.

7 months ago

sagitter edited this update.

New build(s):

  • coin-or-Ipopt-3.12.13-5.el7

Karma has been reset.

7 months ago

FEDORA-EPEL-2019-f4b323778a ejected from the push because "Cannot find relevant tag for coin-or-Ipopt-3.12.13-5.el7. None of ['epel7-testing', 'epel7-testing-pending', 'epel7-signing-pending'] are in ['dist-6E-epel-testing-candidate', 'epel7-testing-candidate', 'dist-5E-epel-testing-candidate', 'f27-modular-updates-candidate', 'f30-modular-updates-candidate', 'f30-container-updates-candidate', 'f30-flatpak-updates-candidate', 'f28-modular-updates-candidate', 'f28-container-updates-candidate', 'epel8-testing-candidate', 'f31-modular-updates-candidate', 'f32-container-updates-candidate', 'f31-container-updates-candidate', 'f31-flatpak-updates-candidate', 'f29-modular-updates-candidate', 'f29-container-updates-candidate', 'f29-flatpak-updates-candidate', 'f22-updates-candidate', 'f21-updates-candidate', 'f25-updates-candidate', 'f24-updates-candidate', 'f23-updates-candidate', 'f26-updates-candidate', 'f27-updates-candidate', 'f30-updates-candidate', 'f28-updates-candidate', 'f31-updates-candidate', 'f32-updates-candidate', 'f29-updates-candidate', 'el8-modular-updates-candidate']."

7 months ago

This update has been submitted for testing by sagitter.

7 months ago

I see possible issue with petsc4py-3.11.0-11.el7 - I tried to rebuild it on mock and %check part fails with error:

I used default epel-7-x86_64.cfg with only modification being epel testing enabled for test build.

ImportError: libdmumps-5.2.so: cannot open shared object file: No such file or directory

ImportError: libdmumps-5.2.so: cannot open shared object file: No such file or directory

Have you installed MUMPS-5.2.1-3.el7 and petsc-3.11.3-9.el7 ?

Scratch build against petsc-3.11.3-9.el7 build root override: https://koji.fedoraproject.org/koji/taskinfo?taskID=39973037

See MUMPS commit 4df584d935e06c4830ccfea555cef042d8de3ef8 - that includes changes which require scalapack-2.1.0 while epel7 still has scalapack-2.0.2 - Could this be the source for issues I see?

Ok. That is missing BR: MUMPS in petsc4py. dnf on build system can pull that in but epel7 version of mock which still uses yum on el7 based systems can't pull it in.

Yes, MUMPS must be rebuilt for scalapack-2.1* changes. Thanks.

Both python36-petsc4py-openmpi and python2-petsc4py-openmpi were also missing Requires: MUMPS%{?_isa} which requirement at least rhel7 rpm can't find.

sagitter edited this update.

New build(s):

  • MUMPS-5.2.1-4.el7
  • psblas3-3.6.1-5.el7
  • mld2p4-2.2.1-4.el7
  • petsc-3.11.3-10.el7
  • petsc4py-3.11.0-12.el7
  • sundials-4.1.0-8.el7

Removed build(s):

  • mld2p4-2.2.1-2.el7
  • MUMPS-5.2.1-3.el7
  • petsc-3.11.3-9.el7
  • petsc4py-3.11.0-11.el7
  • psblas3-3.6.1-3.el7
  • sundials-4.1.0-7.el7

Karma has been reset.

6 months ago

This update has been submitted for testing by sagitter.

6 months ago

This update has been pushed to testing.

6 months ago

This update can be pushed to stable now if the maintainer wishes

6 months ago

This update has been submitted for stable by bodhi.

6 months ago

This update has been pushed to stable.

6 months ago

Please login to add feedback.

Metadata
Type
enhancement
Severity
medium
Karma
0
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
3
Stable by Time
14 days
Dates
submitted
7 months ago
in testing
6 months ago
in stable
6 months ago
modified
6 months ago
BZ#1711291 Need to require scalapack explicitly
0
0

Automated Test Results