FEDORA-EPEL-2020-b6a455afdf created by sagitter 4 months ago for Fedora EPEL 7
stable
  • Release 3.17.1

This update has been submitted for testing by sagitter.

4 months ago

This update's test gating status has been changed to 'waiting'.

4 months ago

This update's test gating status has been changed to 'ignored'.

4 months ago

This update has been pushed to testing.

4 months ago
User Icon denisarnaud commented & provided feedback 4 months ago
karma

Awesome!

I indeed wanted to make it available too!

Just wondering how you got around the zstd support issue in libarchive? See for instance https://bugzilla.redhat.com/show_bug.cgi?id=1827927

User Icon denisarnaud commented & provided feedback 4 months ago

Will you make it available on EPEL 8 too?

User Icon sagitter commented & provided feedback 4 months ago

Just wondering how you got around the zstd support issue in libarchive?

CMake3 on EPEL7 is built against system's libarchive-3.1.2 and libzstd-1.4.4

Will you make it available on EPEL 8 too?

Appstream repositories already provide CMake-3.11.4

User Icon sagitter commented & provided feedback 4 months ago

CMake3 on EPEL7 is built against system's libarchive-3.1.2 and libzstd-1.4.4

No, sorry. libarchive is bundled in this release. CMake-3.17.1 needs libarchive >= 3.3.3

User Icon denisarnaud commented & provided feedback 4 months ago

Will you make it available on EPEL 8 too?

Appstream repositories already provide CMake-3.11.4

Yes, I know. But CMake-3.11 is too old for some of the packages I would like to have on CentOS 8, especially with respect to the support of Python 3 and Boost.Python.

For instance, without more recent CMake versions, it is really tricky to have consistent versions of Python libraries and Boost.Python. Right now, to build those (not yet in EPEL) packages (e.g., in Docker images), I have to bundle the CMake binary; I would rather install CMake from the standard EPEL repository.

sagitter edited this update.

New build(s):

  • cmake3-3.17.1-2.el7

Removed build(s):

  • cmake3-3.17.1-1.el7

Karma has been reset.

4 months ago

This update has been submitted for testing by sagitter.

4 months ago

This update has been pushed to testing.

4 months ago
User Icon sagitter commented & provided feedback 4 months ago

Yes, I know. But CMake-3.11 is too old for some of the packages I would like to have on CentOS 8, especially with respect to the support of Python 3 and Boost.Python.

I don't know if we can spread another CMake3-3* RPM on EPEL8 together original CMake-3* from CentOS 8. But i may provide to you a src-rpm for building it outside official repositories (like a dedicated Copr project).

This update can be pushed to stable now if the maintainer wishes

3 months ago

This update has been submitted for stable by bodhi.

3 months ago

This update has been pushed to stable.

3 months ago

Please login to add feedback.

Metadata
Type
enhancement
Severity
medium
Karma
0
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
3
Stable by Time
14 days
Dates
submitted
4 months ago
in testing
4 months ago
in stable
3 months ago
modified
4 months ago
BZ#1811358 CPackRPM:Debug: *** error: Unknown tag: Suggests:
0
0

Automated Test Results