FEDORA-EPEL-2021-94223daee0 created by vokac 6 months ago for Fedora EPEL 7
obsolete
  • bufix LCGDM-2967
  • improvements in build dependencies

  • bugfixes LCGDM-2958, LCGDM-2961, LCGDM-2963, LCGDM-2964, OOB reads
  • improvements LCGDM-2943, LCGDM-2959, LCGDM-2962, davs speed

  • bugfix update for LCGDM-2953
  • dropped update for IAM group normalization LCGDM-2950

  • bugfixes LCGDM-2948, LCGDM-2949, LCGDM-2950, LCGDM-2954, LCGDM-2955, LCGDM-2957

  • bugfixes LCGDM-2940, LCGDM-2941, LCGDM-2945, LCGDM-2946, LCGDM-2951
  • xrootd plugin library versions configuration cleanup (requires xrootd config file update / puppet run)

This update has been submitted for testing by vokac.

6 months ago

This update's test gating status has been changed to 'ignored'.

6 months ago

This update's test gating status has been changed to 'waiting'.

6 months ago

This update has obsoleted dmlite-1.14.2-6.el7, and has inherited its bugs and notes.

6 months ago

vokac edited this update.

6 months ago

This update's test gating status has been changed to 'ignored'.

6 months ago

This update has been pushed to testing.

6 months ago

dpm-tester.py fails with GError: Could not get the checksum (Invalid argument) or GError: checksum calculation for md5 not supported , in dmlite-1.14.2-1.el7 it works fine

Checksum test is now enabled also for xroot protocol and that means xroot MD5 checksum test was not executed at all in dmlite-1.14.2-1.el7. Still it is not clear where this error message comes from and what exactly does this mean (not able to reproduce this issue with updated EL7 and normal/puppet dmlite configuration).

I can manually get md5 checksum with gfal-sum both for root and davs but for root dpm-tester fails with error GError: Could not get the checksum (Invalid argument). Verify md5 checksum test succeeded for davs with 1.14.2-1.el7 but fails for 1.14.2-7.el7 with other error GError: checksum calculation for md5 not supported for davs. Should server side also be updated to 1.14.2-7.el7 (now with dmlite-1.14.2-1.el7 there)?

Calculating checksums is broken by current patch for LCGDM-2958, this needs to be fixed in a way that's compatible with previous dmlite version ... I'll create 1.14.2-8 soon.

This update has been obsoleted by dmlite-1.14.2-8.el7.

6 months ago

Please login to add feedback.

Metadata
Type
bugfix
Karma
0
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
disabled
Stable by Time
disabled
Dates
submitted
6 months ago
in testing
6 months ago
modified
6 months ago

Automated Test Results