FEDORA-FLATPAK-2019-619c0a6211 created by kalev a year ago for Fedora 30 Flatpaks
stable

New upstream version (70.0). Release notes at https://www.mozilla.org/en-US/firefox/70.0/releasenotes/

This update has been submitted for testing by kalev.

a year ago

This update's test gating status has been changed to 'waiting'.

a year ago

This update has obsoleted firefox-master-3020191015151427.1, and has inherited its bugs and notes.

a year ago

This update's test gating status has been changed to 'ignored'.

a year ago

kalev edited this update.

a year ago

This update has been pushed to testing.

a year ago
User Icon markotaris commented & provided feedback a year ago
karma

Works just fine.

This update has been submitted for stable by bodhi.

a year ago

This update has been pushed to stable.

a year ago
User Icon sumomo commented & provided feedback a year ago
karma

On Centos 8 Firefox 69 worked great, but now when I try to update I get Can't pull from untrusted non-gpg verified remote

I know Centos 8 does not have a new enough version for openh264, but this has not caused any problems on FF69. Platform.openh264/x86_64/19.08 needs a later flatpak version (1.4.2;1.2.5;1.0.9;)

I originally added the repo with flatpak remote-add --if-not-exists fedora oci+https://registry.fedoraproject.org

flatpak update
Looking for updates...
Installing in system:
org.freedesktop.Platform.openh264/x86_64/19.08 flathub 563e6c1a7173
Updating in system:
org.mozilla.Firefox/x86_64/stable fedora 445138d3b3fb
Is this ok [y/n]: y
Updating: org.mozilla.Firefox/x86_64/stable from fedora
Error: Failed to update org.mozilla.Firefox/x86_64/stable: Can't pull from untrusted non-gpg verified remote
Installing: org.freedesktop.Platform.openh264/x86_64/19.08 from flathub
Warning: Failed to install org.freedesktop.Platform.openh264/x86_64/19.08: runtime/org.freedesktop.Platform.openh264/x86_64/19.08 needs a later flatpak version (1.4.2;1.2.5;1.0.9;)
error: There were one or more errors

@sumomu, "Can't pull from untrusted non-gpg verified remote" sounds like an issue with flatpak, not this update

As for the openh264 error, the error is completely unrelated to this update. It's trying to say that the openh264 update from flathub (not from fedora) requires a newer flatpak version than what's available from centos. This should already be fixed as part of https://bugzilla.redhat.com/show_bug.cgi?id=1754450 in RHEL 7.7.

@kalev Thanks for the update. I saw in a bugzilla report that Centos 8 Flatpak will also get the update that enables openh264 soon before Centos/RHEL 8.1 comes out.

As for the "Can't pull from untrusted non-gpg verified remote", I don't see how this can be a flatpak issues. Flatpak and my machine config has remained identical since I successfully installed Firefox 69, so something must have changed with Firefox 70 OR with the Fedora flatpak repo config. Can you think of any such change? Cheers!

Sorry, I don't know. I would suspect something in flatpak OCI backend is not working right. Maybe wait and see if the RHEL flatpak update improves things? Or maybe RHEL flatpak needs some OCI patches backported? This update installs just fine on Fedora.

@kalev Do you know where and to whom I can report this bug? I have a redhat Bugzilla account and fedora project account. I asked for help on the Reddit Centos and Fedora forums and no input other than turn off the gpg in the repo.

You could maybe file it against flatpak in Redhat Enterprise Linux 8 in bugzilla.redhat.com


Please login to add feedback.

Metadata
Type
enhancement
Karma
0
Signed
Content Type
Flatpak
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
1
Stable by Time
7 days
Dates
submitted
a year ago
in testing
a year ago
in stable
a year ago
modified
a year ago

Automated Test Results