FEDORA-MODULAR-2019-a743c925b6

enhancement update in Fedora 30 Modular for bat:latest and exa:latest

Status: obsolete

Rebuild against libgit2:0.28


Update to 0.11.0

Comments 12

This update has been submitted for testing by ignatenkobrain.

This update test gating status has been changed to 'waiting'.

This update has obsoleted bat-latest-3020190601072940.552c3bf4, and has inherited its bugs and notes.

This update test gating status has been changed to 'ignored'.

This update has been pushed to testing.

This upgrade is braking distribution, because the new module requires libgit2: [0.28], but older modules requires libgit2: [0.27]. It is impossible to enable multiple streams or content from multiple streams at the same time.

karma: -1

Bodhi is disabling automatic push to stable due to negative karma. The maintainer may push manually if they determine that the issue is not severe.

getting complaints from dnf about requiring libg2:0.28 even though, as far as I can see, I don't have the bat/exa modules installed or enabled.

Problem 1: module bat:latest:3020190608081801:3494d9fa-0.x86_64 requires module(libgit2:0.28), but none of the providers can be installed
 - module libgit2:0.28:3020190304210604:a5b0195c-0.x86_64 conflicts with module(libgit2:0.27) provided by libgit2:0.27:3020190304180745:a5b0195c-0.x86_64
 - module libgit2:0.27:3020190304180745:a5b0195c-0.x86_64 conflicts with module(libgit2:0.28) provided by libgit2:0.28:3020190304210604:a5b0195c-0.x86_64
 - module libgit2:0.28:3020190407181355:a5b0195c-0.x86_64 conflicts with module(libgit2:0.27) provided by libgit2:0.27:3020190304180745:a5b0195c-0.x86_64
 - module libgit2:0.27:3020190304180745:a5b0195c-0.x86_64 conflicts with module(libgit2:0.28) provided by libgit2:0.28:3020190407181355:a5b0195c-0.x86_64
 - module libgit2:0.28:3020190606170438:a5b0195c-0.x86_64 conflicts with module(libgit2:0.27) provided by libgit2:0.27:3020190304180745:a5b0195c-0.x86_64
 - module libgit2:0.27:3020190304180745:a5b0195c-0.x86_64 conflicts with module(libgit2:0.28) provided by libgit2:0.28:3020190606170438:a5b0195c-0.x86_64
 - module bat:latest:3020190424130937:552c3bf4-0.x86_64 requires module(libgit2:0.27), but none of the providers can be installed
 - conflicting requests
Problem 2: module exa:latest:3020190608082828:3494d9fa-0.x86_64 requires module(libgit2:0.28), but none of the providers can be installed

v - module libgit2:0.28:3020190304210604:a5b0195c-0.x86_64 conflicts with module(libgit2:0.27) provided by libgit2:0.27:3020190304180745:a5b0195c-0.x86_64 - module libgit2:0.27:3020190304180745:a5b0195c-0.x86_64 conflicts with module(libgit2:0.28) provided by libgit2:0.28:3020190304210604:a5b0195c-0.x86_64 - module libgit2:0.28:3020190407181355:a5b0195c-0.x86_64 conflicts with module(libgit2:0.27) provided by libgit2:0.27:3020190304180745:a5b0195c-0.x86_64 - module libgit2:0.27:3020190304180745:a5b0195c-0.x86_64 conflicts with module(libgit2:0.28) provided by libgit2:0.28:3020190407181355:a5b0195c-0.x86_64 - module libgit2:0.28:3020190606170438:a5b0195c-0.x86_64 conflicts with module(libgit2:0.27) provided by libgit2:0.27:3020190304180745:a5b0195c-0.x86_64 - module libgit2:0.27:3020190304180745:a5b0195c-0.x86_64 conflicts with module(libgit2:0.28) provided by libgit2:0.28:3020190606170438:a5b0195c-0.x86_64 - module exa:latest:3020190424131210:552c3bf4-0.x86_64 requires module(libgit2:0.27), but none of the providers can be installed - conflicting requests

This update has reached 7 days in testing and can be pushed to stable now if the maintainer wishes

As per above comment.

karma: -1

Would have been nice if the maintainer could have unpushed the update themselves as it was causing distro wide breakage...

karma: -1

This update has been obsoleted.

Add Comment & Feedback

Please login to add feedback.

Content Type
Module
Status
obsolete
Test Gating
Submitted by
Update Type
enhancement
Update Severity
unspecified
Karma
-3
stable threshold: 1
unstable threshold: -3
Autopush (karma)
Disabled
Autopush (time)
Disabled
Dates
submitted 2 months ago
in testing 2 months ago

Related Bugs 1

00 #1710638 rust-bat-0.11.0 is available

Automated Test Results