FEDORA-2018-e8bc8d2784

security update in Fedora 26 for php

Status: stable 9 months ago

PHP version 7.1.15 (01 Mar 2018)

Apache2Handler:

  • Fixed bug #75882 (a simple way for segfaults in threadsafe php just with configuration). (Anatol)

Date:

  • Fixed bug #75857 (Timezone gets truncated when formatted). (carusogabriel)
  • Fixed bug #75928 (Argument 2 for DateTimeZone::listIdentifiers() should accept null). (Pedro Lacerda)
  • Fixed bug #68406 (calling var_dump on a DateTimeZone object modifies it). (jhdxr)

PGSQL:

  • Fixed #75838 (Memory leak in pg_escape_bytea()). (ard_1 at mail dot ru)

ODBC:

  • Fixed bug #73725 (Unable to retrieve value of varchar(max) type). (Anatol)

LDAP:

  • Fixed bug #49876 (Fix LDAP path lookup on 64-bit distros). (dzuelke)

libxml2:

  • Fixed bug #75871 (use pkg-config where available). (pmmaga)

Phar:

  • Fixed bug #65414 (deal with leading slash when adding files correctly). (bishopb)

SPL:

  • Fixed bug #74519 (strange behavior of AppendIterator). (jhdxr)

Standard:

  • Fixed bug #75916 (DNS_CAA record results contain garbage). (Mike, Philip Sharp)
  • Fixed bug #75981 (stack-buffer-overflow while parsing HTTP response). (Stas)

Comments 7

This update has been submitted for testing by remi.

This update has been pushed to testing.

remi edited this update.

This update has reached 7 days in testing and can be pushed to stable now if the maintainer wishes

This update has been submitted for batched by remi.

This update has been submitted for stable by remi.

This update has been pushed to stable.


Add Comment & Feedback
Toggle Preview

Comment fields support Fedora-Flavored Markdown. Comments are governed under this privacy policy.

-1 0 +1 Feedback Guidelines

Is the update generally functional? (karma)

You need to be logged in to add karma!

#1551039 CVE-2018-7584 php: Stack-based buffer under-read in ext/standard/http_fopen_wrapper.c:php_stream_url_wrap_http_ex function when parsing HTTP response allows denial of service
#1551040 CVE-2018-7584 php: Stack-based buffer under-read in ext/standard/http_fopen_wrapper.c:php_stream_url_wrap_http_ex function when parsing HTTP response allows denial of service [fedora-all]
Content Type
RPM
Status
stable
Test Gating
Submitted by
Update Type
security
Update Severity
unspecified
Karma
0
stable threshold: 3
unstable threshold: -3
Autopush
Enabled
Dates
submitted 10 months ago
in testing 10 months ago
in stable 9 months ago
modified 9 months ago

Related Bugs 2

00 #1551039 CVE-2018-7584 php: Stack-based buffer under-read in ext/standard/http_fopen_wrapper.c:php_stream_url_wrap_http_ex function when parsing HTTP response allows denial of service
00 #1551040 CVE-2018-7584 php: Stack-based buffer under-read in ext/standard/http_fopen_wrapper.c:php_stream_url_wrap_http_ex function when parsing HTTP response allows denial of service [fedora-all]

Automated Test Results